Wednesday, July 25, 2012

We could not complete your purchase

I have a lightly used Core 2 Duo MacBook that I thought I'd upgrade to Mountain Lion, but I encountered an unexpected issue in the App Store: "We could not complete your purchase. OS X Mountain Lion is not compatible with this computer."

Requirements: "OS X 10.6.8 or later"

About This Mac says "Mac OS X Version 10.6.8"

How did Tim know that I didn't need this and should be doing something productive?


James said...

I have the same issue. I have an early 2008 Macbook, as far as I can see I have the tech specs I need, but keep getting the message, "We could not complete your purchase. OS X Mountain Lion is not compatible with this computer."

Any help would be brilliant!

Ross said...

I have exactly the same issue - running 10.7.4 on an early 2008 macbook. if anyone can help that would be fab!

Shimal said...

I have an Imac with 10.7 later and i tried to to buy the new version of OS X Mountain Lion but it says We could not complete your purchase. OS X Mountain Lion is not compatible with this computer.

Jeff Trawick said...

I just found a requirements page at For MacBook it says simply "MacBook (Late 2008 Aluminum, or Early 2009 or newer)". I bought my white MacBook in early 2009, but perhaps it was a slightly older model.

WAKAMA said...

I am having the same problem and found the following three posts with helpful information about it:




I posted my thoughts about this on the Apple Support Community forum listed above, but Apple quickly removed it (literally within a few minutes), because it contained "Discussion of Apple Policies, Procedures or Decisions". So here's a copy of that post with my thoughts on this...

"Seriously Apple??!! You’ve GOT TO BE KIDDING!! If you're looking to loose clientele fast, this is a GREAT WAY to do it!

I completely agree that you need to have minimum requirements such as OS X v10.6.8 or later, 2GB of memory, 8GB of available space in order to upgrade to the latest OS. That’s perfectly reasonable. BUT… telling us that we need to have a Mac from a more recent year, even if our current one far exceeds those other minimum hardware/software requirements… THAT’S ABSOLUTELY RIDICULOUS APPLE!!! That’s just a way to try to milk your past customers for new cash and its UNACCEPTABLE! Take for example the system that MHaddon mentions in his post above, which has:

2 x 3 GHz Dual-Core Intel Xeon
Memory: 16 GB
Graphics: ATI Radeo HD 5770 1024 MB
Software: Mac OS X Lion 10.7.4

Are you SERIOUSLY expecting folks to spend another $4,000 on a new system with similar specs simply because they bought theirs prior to 2008 or whatever date is it???!!! I DON’T THINK SO! THIS IS ABSURD APPLE! Seriously, GET A GRIP!"

WAKAMA said...

By the way, if anyone else thinks similarly, please let Apple know at

USMA 1970 said...

"We could not complete your purchase. OS X Mountain Lion is not compatible with this computer."

MacPro Mac OS X.74 2x2.66 GHz Dual-Core Xeon

So it is old? Can't upgrade? Seriously???

WAKAMA said...

According to Apple it is. My thought... BOYCOTT!!

Robert Seipp said...

Let CNET, WSJ, Macworld, and everyone know..
I'm in the same position..Mac-Mini has all the specs but App store will not let me download Mountain Lion because of the date of Manufacture of my machine..

There's gotta be a way to basically "jailbreak" this..
Anybody have some ideas??

Earl Dee said...

This is ridiculous! I have the early 2008 macbook so I can't upgrade to lion.

This is really a big competitive loss for apple since pcs don't have a problem.

Madame BĂȘte Noire said...

So what the hell are we supposed to do? I need to activate iCloud on my mac and also can't complete the purchase!